TL-WR703N 刷 OpenWrt后设置中继的方法

如果你用TL-WR703N官方固件设置中继总不成功,那还是刷OpenWrt吧。刷机方法见《TL-WR703N刷官方OpenWrt固件(14.07)实现3G+wifidog(微信认证)》第一部分。

固件刷完之后,用winscp连接WR703N修改两个文件:

#/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.10.1'
option netmask '255.255.255.0'

config interface 'wwan'
option proto 'dhcp'

#/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'platform/ar933x_wmac'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option htmode 'HT20'
option disabled '0'
option channel '1'
option txpower '27'
option country 'US'

config wifi-iface
option network 'wwan'
option ssid '【主AP的essid】'
option encryption 'psk2' #【主AP的加密方式】
option device 'radio0'
option mode 'sta'
option bssid '【主AP的bssid】'
option key '【主AP的密码】'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt'
option network 'lan'
option encryption 'psk2'
option key '00000000'

这里要注意几点:

按照上述方法刷新固件之后,路由器管理IP变为 192.168.10.1 所以,在用网线连接WR703N的时候,电脑IP也需要设置为 192.160.10.x

上述配置文件只是临时的,我们还需要手动变更WR703N的wifi设置,按照下面两张图配置即可:

(图一)

(图二)

配置完成后,在wifi界面看到的应该是这样:

(图三)

若要变更上级路由,比如更换环境了,那么上级路由的SSID可以通过扫描(scan)获得,在知道上级路由的密码的情况下,我们就可以顺利接入上级路由了。

本机(中继设备WR703N)的安全设置比如接入密码,均可以在本机的设置界面(图二)操作。

发表评论

电子邮件地址不会被公开。 必填项已用*标注